logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
AM2001  
#1 Posted : Wednesday, October 7, 2015 1:40:27 AM(UTC)
AM2001


Rank: Newbie

Joined: 10/7/2015(UTC)
Posts: 4
Canada
Location: Montreal

I'm having a problem with my app.config settings. It seems when I have more than one setting under the "<ScreenConnect.UserInterfaceSettings>" tag, none of the settings are applied (i.e neither the HideWallpaperOnConnect or ShowSystemTrayIcon settings are picked up). However, when I only have one setting listed, it applies that setting. I'm on SC 5.4. Any ideas? Below is a copy of the code I've been using.

Code:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
	<configSections>
		<section name="ScreenConnect.SystemSettings" type="System.Configuration.ClientSettingsSection"></section>
                <section name="ScreenConnect.UserInterfaceSettings" type="System.Configuration.ClientSettingsSection"></section>
	</configSections>
	<ScreenConnect.SystemSettings>
		<setting name="AutoConsentIfUserProcessNotRunning" serializeAs="String"><value>true</value></setting> 
	</ScreenConnect.SystemSettings>
	<ScreenConnect.UserInterfaceSettings>
		<setting name="HideWallpaperOnConnect" serializeAs="String"><value>false</value></setting>
		<setting name="ShowSystemTrayIcon" serializeAs="String"><value>false</value></setting>
	</ScreenConnect.UserInterfaceSettings>
</configuration>

rgreen83  
#2 Posted : Wednesday, October 7, 2015 3:19:23 PM(UTC)
rgreen83


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/16/2015(UTC)
Posts: 69
United States
Location: Missouri

Thanks: 6 times
Was thanked: 3 time(s) in 3 post(s)
I dont have and dont see in the example app.config the </section> closing tag that you have on lines 4 and 5 http://help.screenconnec...ting_the_app.config_file

Other than that I would start with a fresh copy of the example app.config and then add your changes keeping with the existing formatting e.g. values on new lines instead of in-line, not sure if that formatting affects anything but it makes it easier to compare to others.
AM2001  
#3 Posted : Wednesday, October 7, 2015 4:04:01 PM(UTC)
AM2001


Rank: Newbie

Joined: 10/7/2015(UTC)
Posts: 4
Canada
Location: Montreal

Hmmm... You're right! I played around with it and you can't change the formatting from the example. It's odd as XML should be able to be read no matter how much white-space is added/removed.

It's working now, thanks!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.