logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
LaSepp  
#1 Posted : Friday, February 3, 2012 5:39:53 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 54
Man
Germany

Thanks: 2 times
Was thanked: 19 time(s) in 10 post(s)
As I have been using ScreenConnect for some time I started writing some small helper programs.
In the spirit of idea exchange and to help others not to have to do the same work all over I've decided to share them with you.

Here's the first (really small) tool that may help some of you out there:

ScreenConnect SupportTool is a simple browser window to allow quick access to the ScreenConnect Session List:

UserPostedImage

Distribution:
To allow for individual distribution the .exe file is launched with the URL to the ScreenConnect Site as parameter.
This offers two possibilities for distribution:
1. Shortcut
Simply copy the .exe file to a common network share and put a shortcut to SupportTool with the URL as parameter in every user's start menu or desktop.
2. Self Extracting .exe
Wrap the SupportTool.exe into a self-Extracting .exe file by use of your favorite packaging tool and set it to extract to temp folder and open the SupportTool.exe with parameter.
A quite unknown tool to accomplish that is distributed alongside Windows: IExpress.
Try writing "iexpress" in Windows Run Dialog and follow the wizard.

Alternate usage
SupportTool can be used as a tool to give your technicians a single point of usage.
It can be pinned to the Start Menu and you have a chrome-free separate browser window.
If ScreenConnect runs with Active Directory Authentication all you need to do is add the ScreenConnect URL to your "Local Network" Sites in IE and a Link to e.g. http://screenconnect.yourdomain.com/Host will give you Single Sign On

Requirements:
* Windows OS
* .NET Framework 2.0

Download:
* Download Page
* Direct Download
thanks 1 user thanked LaSepp for this useful post.
FilthX on 1/6/2017(UTC)

Jake  
#2 Posted : Thursday, February 9, 2012 11:33:48 AM(UTC)
Jake


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/9/2010(UTC)
Posts: 2,061

Thanks: 1 times
Was thanked: 393 time(s) in 188 post(s)
Thanks for providing this. It seems like it it could be used for anything ... very similar to Chrome's "application mode".
ScreenConnect Team
Up2Date  
#3 Posted : Sunday, August 26, 2012 8:51:16 PM(UTC)
Up2Date


Rank: Member

Joined: 9/7/2011(UTC)
Posts: 14
Location: Aus

excellent tool, though Create Sessions doesn't work. Get a script error
LaSepp  
#4 Posted : Monday, August 27, 2012 4:26:25 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 54
Man
Germany

Thanks: 2 times
Was thanked: 19 time(s) in 10 post(s)
Up2Date wrote:
excellent tool, though Create Sessions doesn't work. Get a script error


I know this one...
There is some trick to manipulate IE Settings so this does work - but I don't like the idea of changing IE Settings in a Remote Access Tool.
But if you like I can go ahead and search for the REG File to do this so it can be used on Tech PCs.

The other trick that makes this work is quite strange and may have other side effects (we're using this, until now there is no problem with it):
On the Server go to your "Default.master" file and change

Default.Master wrote:
<meta http-equiv="X-UA-Compatible" content="IE=9" />

to
Default.Master wrote:
<meta http-equiv="X-UA-Compatible" content="IE=8" />


This way the only thing that doesn't work will be the search field...
myers6mm  
#5 Posted : Tuesday, December 17, 2013 1:47:12 PM(UTC)
myers6mm


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 9/5/2013(UTC)
Posts: 64
Man
Location: Central Kannsas

Thanks: 25 times
Was thanked: 5 time(s) in 5 post(s)
Hello LaSepp,

First let me say thank you for this handy tool!

Could you help me figure out why the icons don't look right when I use this? Everything seems to work as it should just a visual thing. More than likely I'm doing something wrong.

I put the actual SupportTool.exe in Dropbox and created a desktop shortcut to it including my ScreenConneect site in the target line of the shortcut. I'm trying to run it on Win 7 Pro 64 Bit.


UserPostedImage

Any help would be appreciated, Mike.
Jeff  
#6 Posted : Tuesday, December 17, 2013 3:33:53 PM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
Almost looks like an issue with older IE versions and the host page. Have you tried a different browser?
ScreenConnect Team
thanks 1 user thanked Jeff for this useful post.
myers6mm on 12/20/2013(UTC)
myers6mm  
#7 Posted : Tuesday, December 17, 2013 3:48:11 PM(UTC)
myers6mm


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 9/5/2013(UTC)
Posts: 64
Man
Location: Central Kannsas

Thanks: 25 times
Was thanked: 5 time(s) in 5 post(s)
Thank you Jeff!
I've been using this .exe at work and they haven't let us update I.E. past 8 yet! I just logged into another machine with a I.E. 11 and it works just fine.

Thanks again.
LaSepp  
#8 Posted : Wednesday, December 18, 2013 3:41:27 AM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 54
Man
Germany

Thanks: 2 times
Was thanked: 19 time(s) in 10 post(s)
Hi myers6mm,

I've updated the .EXE File to use (if available) newer IE Engines.
Please try again with the new version.
thanks 1 user thanked LaSepp for this useful post.
myers6mm on 12/20/2013(UTC)
myers6mm  
#9 Posted : Friday, December 20, 2013 12:17:47 PM(UTC)
myers6mm


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 9/5/2013(UTC)
Posts: 64
Man
Location: Central Kannsas

Thanks: 25 times
Was thanked: 5 time(s) in 5 post(s)
Hello LaSepp,

I tried your updated .EXE but had the same result. I then updated the PC to I.E. 9 and it works just fine.

Thanks, Mike.
promptcare  
#10 Posted : Friday, February 7, 2014 12:19:35 AM(UTC)
promptcare


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 2: Lent a Helping Hand! 10 Thanks!

Joined: 9/14/2011(UTC)
Posts: 360
Location: ON, Canada

Thanks: 31 times
Was thanked: 14 time(s) in 11 post(s)
Nice tool but, when running, it uses 15-17% CPU while idling.
LaSepp  
#11 Posted : Friday, February 7, 2014 1:41:55 PM(UTC)
LaSepp


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 7/22/2011(UTC)
Posts: 54
Man
Germany

Thanks: 2 times
Was thanked: 19 time(s) in 10 post(s)
Hi promptcare,

I just tried it and I can reproduce the CPU load.
The tool just uses an embedded Internet Explorer window - so I couldn't imagine how the tool itself could use up CPU like that.
So I tried it with my local IE and had a iexplore.exe process running ~8-12% CPU, exactly the same as I get running SupportTool.exe
Just navigate away from the "Host" page to - for example - Admin and the CPU load will drop to 0% in a matter of seconds...

So maybe this one will have to be solved by the SC team...
myers6mm  
#12 Posted : Tuesday, April 15, 2014 4:19:58 PM(UTC)
myers6mm


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 9/5/2013(UTC)
Posts: 64
Man
Location: Central Kannsas

Thanks: 25 times
Was thanked: 5 time(s) in 5 post(s)
Hello LaSepp,

I'm now trying to use your tool on 2 different Windows 8.1 computers. The tool opens just fine but I'm receiving the following error when I try to connect to any machine.


Error
nikonie  
#13 Posted : Wednesday, April 16, 2014 11:16:11 AM(UTC)
nikonie


Rank: Newbie

Joined: 4/8/2014(UTC)
Posts: 8
Finland

Thanks: 1 times
Originally Posted by: myers6mm Go to Quoted Post
Hello LaSepp,

I'm now trying to use your tool on 2 different Windows 8.1 computers. The tool opens just fine but I'm receiving the following error when I try to connect to any machine.


Error


I'm getting same error on Windows 8.1 computer. Works fine with Windows 7.
reach2rv  
#14 Posted : Wednesday, April 16, 2014 12:01:26 PM(UTC)
reach2rv


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 11/14/2013(UTC)
Posts: 48

Thanks: 11 times
Was thanked: 12 time(s) in 5 post(s)
Originally Posted by: nikonie Go to Quoted Post
Originally Posted by: myers6mm Go to Quoted Post
Hello LaSepp,

I'm now trying to use your tool on 2 different Windows 8.1 computers. The tool opens just fine but I'm receiving the following error when I try to connect to any machine.


Error


I'm getting same error on Windows 8.1 computer. Works fine with Windows 7.


it is because of the enhance security of temp folder in windows 8. I have tried with disabling enhance mode of IE but it doesn't work. I even tried with moving temp file location but still it fails.

I recommend using
http://forum.screenconne...ide-Support-Session.aspx

Regards,




nikonie  
#15 Posted : Wednesday, April 16, 2014 1:14:46 PM(UTC)
nikonie


Rank: Newbie

Joined: 4/8/2014(UTC)
Posts: 8
Finland

Thanks: 1 times
Originally Posted by: reach2rv Go to Quoted Post


SupportTool would suit much better for me. There is no localization possibility on ScreenConnect Quick Support. Since SupportTool shows information I have already localized it's much easier.

-Niko
reach2rv  
#16 Posted : Wednesday, April 16, 2014 4:40:51 PM(UTC)
reach2rv


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 11/14/2013(UTC)
Posts: 48

Thanks: 11 times
Was thanked: 12 time(s) in 5 post(s)
Originally Posted by: nikonie Go to Quoted Post
Originally Posted by: reach2rv Go to Quoted Post


SupportTool would suit much better for me. There is no localization possibility on ScreenConnect Quick Support. Since SupportTool shows information I have already localized it's much easier.

-Niko


then you can google for clickonce download fails on windows 8.

also i am in process of localizing Quick support. it will be great if you guys can help me with content.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.