logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
manfred.haelters  
#1 Posted : Monday, May 5, 2014 11:32:17 AM(UTC)
manfred.haelters


Rank: Newbie

Joined: 5/5/2014(UTC)
Posts: 2
Belgium

All,

I'm trying to customize the client configuration, so that we can start sessions as read-only. Therefore, we have created an app.config file in the "C:\Program Files (x86)\ScreenConnect\App_ClientConfig" on the ScreenConnect server. (see below for the current contents of the app.config file). However, when we then create a support session, the BlockGuestInput does not seem to be applied. Just to be sure, we have also tried to disable some control panels, but this is also not applied.

When I look at the client, and browse to a subdir of the homedrive 'AppData\Local\Apps\2.0\865LKZZD.7KX\WEOA33VP.2A7\elsi..tion_69acd703c415f77d_0004.0000_2c4a2a3a3db07c32' I do find the app.config file, with the same contents as on the server.

Do we have to enable something extra, are there other ways to troubleshoot... ?

Thanks!




--- app.config file ---
<?xml version="1.0" encoding="utf-8"?>
<configuration>
<configSections>
<section name="Elsinore.ScreenConnect.UserInterfaceSettings" type="System.Configuration.ClientSettingsSection" />
</configSections>
<Elsinore.ScreenConnect.UserInterfaceSettings>
<setting name="DisabledCommandNames" serializeAs="String">
<value>BlockGuestInput</value>
</setting>
<setting name="ControlPanelIds" serializeAs="String">
<value>0x0000011114100000</value>
</setting>
</Elsinore.ScreenConnect.UserInterfaceSettings>
</configuration>

Scott  
#2 Posted : Monday, May 5, 2014 1:04:24 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
Have you cleared the app cache?

If the server is Windows, run the following command from a command prompt: rundll32 dfshim CleanOnlineAppCache

Also, if the session is an Access session, it will require a reinstall of the remote client in order for the changes to propagate.
ScreenConnect Team
manfred.haelters  
#3 Posted : Tuesday, May 6, 2014 6:48:12 AM(UTC)
manfred.haelters


Rank: Newbie

Joined: 5/5/2014(UTC)
Posts: 2
Belgium

Originally Posted by: Scott Go to Quoted Post
Have you cleared the app cache?


Yes the app cache was cleared. This did not provide a solution. (just to be sure, we have run this command both on the server and the client)

Originally Posted by: Scott Go to Quoted Post
Also, if the session is an Access session, it will require a reinstall of the remote client in order for the changes to propagate.

It is a support session.

Any further tips are very welcome!

Jake  
#4 Posted : Tuesday, May 6, 2014 12:09:49 PM(UTC)
Jake


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/9/2010(UTC)
Posts: 2,061

Thanks: 1 times
Was thanked: 393 time(s) in 188 post(s)
You're casing of controlpanelids is wrong, I think
ScreenConnect Team
jswall  
#5 Posted : Wednesday, July 23, 2014 11:09:02 PM(UTC)
jswall


Rank: Newbie

Joined: 7/18/2014(UTC)
Posts: 8
Man
United States
Location: Long Beach, CA

FYI, the casing in the sample on http://help.screenconnec...t_of_app.config_settings is also incorrect. In some places it shows IDs and other Ids.
Scott  
#6 Posted : Thursday, July 24, 2014 12:55:21 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
Thanks for noticing that jswall! I have updated the documentation to reflect the correct syntax.
ScreenConnect Team
jordantiss  
#7 Posted : Friday, January 9, 2015 9:50:32 PM(UTC)
jordantiss


Rank: Newbie

Joined: 1/8/2015(UTC)
Posts: 8
United States

I just ran into a similar problem myself. The first issue was that the DisabledCommandNames setting in <Elsinore.ScreenConnect.SystemSettings> instead of <Elsinore.ScreenConnect.UserInterfaceSettings> as the List of app.config settings page isn't very clear on where the DisabledCommandNames go.

The second issue was that rundll32 dfshim CleanOnlineAppCache didn't work. I had to uninstall and reinstall the client on my computer for the settings to take effect.

The techs at my company have already installed the client. Do they need to reinstall as well for this to take effect on their machine? Or is this setting applied when a customer connects to a support session?

The app.config pages in Help need some work on clarifying things, IMHO. Thanks.
rami.ejailat  
#8 Posted : Sunday, May 3, 2015 5:52:36 PM(UTC)
rami.ejailat


Rank: Newbie

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/3/2015(UTC)
Posts: 7
Man
Jordan

Was thanked: 1 time(s) in 1 post(s)
app.config doesn't get updated on Host (techs) & Guest (customers) unless you force reinstalling :(

I don't know if it's technically possible to auto-update app.config as we don't know if the connecting Support client has the latest version or not.
thanks 1 user thanked rami.ejailat for this useful post.
cristobalcat on 11/19/2015(UTC)
cristobalcat  
#9 Posted : Thursday, November 19, 2015 5:23:35 PM(UTC)
cristobalcat


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group Member

Joined: 11/19/2015(UTC)
Posts: 59
United States
Location: USA

Thanks: 47 times
Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: rami.ejailat Go to Quoted Post
app.config doesn't get updated on Host (techs) & Guest (customers) unless you force reinstalling :(

I don't know if it's technically possible to auto-update app.config as we don't know if the connecting Support client has the latest version or not.


This is very very important to be auto-update. We have a near thousand PC with mandatory SC installation. It is impossible to update manually.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.