logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
basketball34kb  
#1 Posted : Saturday, November 24, 2018 5:22:17 PM(UTC)
basketball34kb


Rank: Guest

Joined: 11/24/2018(UTC)
Posts: 3

How does anyone deal with UAC?

I open something that apparently needs admin rights and everything is just froze. The chat is behind all the other windows so the customer doesn't see anything I send them.
This needs to be fixed, I have several customers that just sit there for 30+ minutes, and I can't do anything unless they happen to click on the chat window so we can communicate.


Telling customer to turn off UAC every time is not an answer. I'm not going to waste 10+ minutes turning off UAC and restarting every single remote support session. I would rather use a different product.

SoCo_Systems  
#2 Posted : Wednesday, November 28, 2018 11:18:42 AM(UTC)
SoCo_Systems


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/29/2014(UTC)
Posts: 130
Man
United States
Location: Indianapolis, IN

Thanks: 2 times
Was thanked: 21 time(s) in 21 post(s)
You seem to have something strange going on with your settings or installs. I have no trouble with UAC prompts. They pop up, I click on them, then move on.
And there is a setting to always keep SC on top, which would take care of your pop-under chat window issue.
Scott  
#3 Posted : Wednesday, November 28, 2018 12:22:16 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
@basketball34kb are you referring to UAC prompts that appear within a Support or Access session?

By default, Access sessions are installed as System and should behave exactly how @SoCo_Systems describes above.

Support sessions, however, behave a bit differently. Since often times a Guest may not be able to run things as System a Support session will launch at whatever level possible. You can, however, pretty easily elevate a Support session by sending a Control-Alt-Delete command from the Essentials menu in the Host client. This CAD command will do one of two things, it will either behave like a normal CAD command if the Guest client is already elevated or it will prompt you for credentials in order to elevate the Guest process. This KB article has some more information on the process.
ScreenConnect Team
basketball34kb  
#4 Posted : Wednesday, November 28, 2018 4:32:58 PM(UTC)
basketball34kb


Rank: Guest

Joined: 11/24/2018(UTC)
Posts: 3

its a support session
the KB article describes the issue, but that means I have to enter admin credentials?

so now I have to ask the customer what their login information is, then do the ctrl alt delte and enter the information?
That seems like a huge security issue asking customer for their password, I would rather tell them to shut off UAC.
Scott  
#5 Posted : Wednesday, November 28, 2018 5:09:29 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
As far as I can remember the prompt appears on the Guest's machine so that either party may enter the credentials.
ScreenConnect Team
basketball34kb  
#6 Posted : Wednesday, November 28, 2018 5:13:17 PM(UTC)
basketball34kb


Rank: Guest

Joined: 11/24/2018(UTC)
Posts: 3

Originally Posted by: Scott Go to Quoted Post
As far as I can remember the prompt appears on the Guest's machine so that either party may enter the credentials.



I will try this next time it happens
SoCo_Systems  
#7 Posted : Wednesday, November 28, 2018 5:49:33 PM(UTC)
SoCo_Systems


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/29/2014(UTC)
Posts: 130
Man
United States
Location: Indianapolis, IN

Thanks: 2 times
Was thanked: 21 time(s) in 21 post(s)
Take a look at the Credential Storage option. (Tools menu - Manage Credentials - Prompt for storage) Your customer can store the admin credentials you'll need in the client software without having to give them to you, and without you needing them to type it in every time.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.