The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.



Go to last post Go to first unread
#1 Posted : Tuesday, October 31, 2017 10:43:17 PM(UTC)

Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/6/2014(UTC)
Posts: 316
United States

Thanks: 6 times
Was thanked: 33 time(s) in 29 post(s)
I initially posted this in Tips and Tricks but was advised by support that it belonged in the Advanced Customization forum instead. Here goes.

I love the "Commands" functionality. It's fantastic. I use it for well over 90% of what I need to do for my clients. But it's not perfect. On macOS I have to enter the complete path for each command which is a waste of time (stuff like '/usr/local/bin/mas list'). That's a PITA.

I'm expanding my tool collection and placing them all within a single folder on the client device. No matter what configuration files I change however, "echo $PATH" always returns "/usr/bin:/bin:/usr/sbin:/sbin".

I've tried adding a new file in /etc/paths.d and a new record in /etc/paths

I've tried /etc/profile

I've tried modifying the onlogin and prelogin LaunchAgents for SC/CC

I've tried creating a new environment.plist launchagent and assigning the path there

Is there a way to get it to do what I want (add my folder to the $PATH)?

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.