logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
mobiletechie  
#1 Posted : Monday, February 12, 2018 2:08:43 PM(UTC)
mobiletechie


Rank: Newbie

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/16/2014(UTC)
Posts: 10

Was thanked: 1 time(s) in 1 post(s)
I've got screenconnect installed on an Ubuntu 16.04 LTS and it's unusably slow - screen redraws and long pauses.


Any ideas?

shawnkhall  
#2 Posted : Monday, February 12, 2018 2:42:07 PM(UTC)
shawnkhall


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/6/2014(UTC)
Posts: 316
Man
United States

Thanks: 6 times
Was thanked: 33 time(s) in 29 post(s)
what version of SC? what are the server specs? what are the network capabilities? are you aware that all traffic for remote control passes thru the server? and if you're using the video recording feature, it could be that the drive is full.
mobiletechie  
#3 Posted : Monday, February 12, 2018 2:47:44 PM(UTC)
mobiletechie


Rank: Newbie

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/16/2014(UTC)
Posts: 10

Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: shawnkhall Go to Quoted Post
what version of SC? what are the server specs? what are the network capabilities? are you aware that all traffic for remote control passes thru the server? and if you're using the video recording feature, it could be that the drive is full.


It's none of that. It's absolutely specific to it being Ubuntu 16.04

The ubuntu machine replaced a windows box sitting in the same place which worked perfectly well. They have 100mbps broadband. Ubuntu works perfectly well over ssh, it's something to do with the way ubuntu is reacting with screenconnect in the headless configuration. I suspect a graphics issue of some kind as some functions, like file transfer work at normal speed - once the screen redraw manages to catch up.
franklinian  
#4 Posted : Thursday, February 22, 2018 3:14:05 AM(UTC)
franklinian


Rank: Newbie

Joined: 7/15/2014(UTC)
Posts: 10
United States

I have been running the latest production versions of SC on ubuntu 16.04 for a long time with no problems (~100 guests).

Some early performance issues I encountered had to do with mono (service was using a disproportionate amount of cpu resources). They went away after I increased system RAM to 4GB (running as a VM guest). Of course, I have kept the OS up to date as well.
mobiletechie  
#5 Posted : Monday, February 26, 2018 4:26:52 PM(UTC)
mobiletechie


Rank: Newbie

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/16/2014(UTC)
Posts: 10

Was thanked: 1 time(s) in 1 post(s)
Turns out it was Ubuntu not liking having not monitor attached. As soon as I attach one, the problem vanish. As soon as I unplug it, they return.
I've ordered a dummy VGA plug which will supposedly solve it without needing an actual monitor.
mobiletechie  
#6 Posted : Monday, February 26, 2018 9:38:06 PM(UTC)
mobiletechie


Rank: Newbie

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/16/2014(UTC)
Posts: 10

Was thanked: 1 time(s) in 1 post(s)
If anyone else runs into this, you can solve it by installing a fake video driver:

$ apt-get install xserver-xorg-video-dummy
$ nano /etc/X11/xorg.conf

Section "Device"
Identifier "Configured Video Device"
Driver "dummy"
EndSection
Section "Monitor"
Identifier "Configured Monitor"
HorizSync 31.5-48.5
VertRefresh 50-70
EndSection
Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1152x864"
EndSubSection
EndSection

It's orders of magnitude faster now.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.