logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Mc128k  
#1 Posted : Wednesday, September 11, 2013 5:08:38 PM(UTC)
Mc128k


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/7/2013(UTC)
Posts: 47
Location: Parma

Thanks: 2 times
Was thanked: 2 time(s) in 2 post(s)
Hi all
I just discovered a nice trick to use in mac servers.

The package for the "unattended" remote control needs the computer to be restarted. But often you don't want it.

Just force quit the installer when it's done (cmd-opt-esc, force quit) and then in a terminal type

Code:
launchctl load /Library/LaunchAgents/com.elsitech.screenconnect.client.plist


And voilà, the app starts.

p.s.: a note to developers, this takes one small step in the setup script. Just do a post-install script that invokes this command. It would be a great feature, after the service-mode remote control.

inevat  
#2 Posted : Wednesday, September 11, 2013 6:15:11 PM(UTC)
inevat


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 9/7/2013(UTC)
Posts: 28
Location: Salt Lake City

Was thanked: 1 time(s) in 1 post(s)
You sir, have my gratitude.
jcwacky  
#3 Posted : Tuesday, January 28, 2014 6:18:49 PM(UTC)
jcwacky


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/23/2014(UTC)
Posts: 32
Man
United Kingdom
Location: Edinburgh, Scotland

Thanks: 2 times
Was thanked: 6 time(s) in 3 post(s)
This still works great on 4.1, but the command to run is:

Code:
launchctl load /Library/LaunchAgents/com.elsitech.screenconnect.client.onlogin.plist


Would be amazing to get this built into the installer!
futura  
#4 Posted : Tuesday, January 28, 2014 7:26:44 PM(UTC)
futura


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/3/2014(UTC)
Posts: 101
Canada

Thanks: 43 times
Was thanked: 11 time(s) in 10 post(s)
+1 - Yes Please!!!!
techtronic  
#5 Posted : Wednesday, January 29, 2014 7:42:57 PM(UTC)
techtronic


Rank: Newbie

Joined: 1/29/2014(UTC)
Posts: 1
United States

I had installed the 4.1.5971 which never connected to my server, I upgraded to 4.1.6036 and ran the new installer on the Macs.

I had to run

launchctl unload /Library/LaunchAgents/com.elsitech.screenconnect.client.onlogin.plist

Then

launchctl load /Library/LaunchAgents/com.elsitech.screenconnect.client.onlogin.plist

And then it connected back and all was well.
expphoto  
#6 Posted : Tuesday, April 7, 2015 3:08:34 PM(UTC)
expphoto


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/16/2015(UTC)
Posts: 28
United States
Location: Arizona

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: jcwacky Go to Quoted Post
This still works great on 4.1, but the command to run is:

Code:
launchctl load /Library/LaunchAgents/com.elsitech.screenconnect.client.onlogin.plist


Would be amazing to get this built into the installer!




I get nothing to load on this one.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.