logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
philipbroadhead  
#1 Posted : Tuesday, December 2, 2014 5:02:11 PM(UTC)
philipbroadhead


Rank: Newbie

Joined: 12/2/2014(UTC)
Posts: 2
United Kingdom
Location: Bromsgrove

Hi guys!

Just trying to install an unattended ScreenConnect session to a Ubuntu 14.04 server we need access to remotely.

I've downloaded the .sh file and run it through Terminal. It seems to have installed correctly but doesn't show in the list of clients to connect to.

I'm pretty new to Ubuntu so won't know the ins and outs of it. Bit confused to say the least.

Any ideas?


Cheers.

Scott  
#2 Posted : Tuesday, December 2, 2014 6:07:41 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
There should be a log file in /var/log. It'll be called something like screenconnect-xxxxxxxxxxxxxxxx where the x's are your ScreenConnect server's public key thumbprint.

If you run a tail -50 command on that logfile, what does it kick out?

Also, is Java installed on the machine and if so, what version?
ScreenConnect Team
philipbroadhead  
#3 Posted : Wednesday, December 3, 2014 9:35:10 AM(UTC)
philipbroadhead


Rank: Newbie

Joined: 12/2/2014(UTC)
Posts: 2
United Kingdom
Location: Bromsgrove

Originally Posted by: Scott Go to Quoted Post
There should be a log file in /var/log. It'll be called something like screenconnect-xxxxxxxxxxxxxxxx where the x's are your ScreenConnect server's public key thumbprint.

If you run a tail -50 command on that logfile, what does it kick out?

Also, is Java installed on the machine and if so, what version?


i've opened the log file up and will paste below:

Quote:
2014-12-02 16:28:53.719 +0000 Exception:
Header Chunk. Image width:22 height:22 depth:8 color type:6 compression type:0 filter type:0 interlace:0
java.lang.NoSuchMethodError: method java.net.Socket.<init> with signature (Ljava.net.Proxy;)V was not found.
at com.elsitech.screenconnect.EndPointManager.run(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.runThread(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.access$000(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner$1.run(Unknown Source)
at java.lang.Thread.run(libgcj.so.14)
2014-12-02 16:29:34.814 +0000 Exception:
Header Chunk. Image width:22 height:22 depth:8 color type:6 compression type:0 filter type:0 interlace:0
java.lang.NoSuchMethodError: method java.net.Socket.<init> with signature (Ljava.net.Proxy;)V was not found.
at com.elsitech.screenconnect.EndPointManager.run(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.runThread(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.access$000(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner$1.run(Unknown Source)
at java.lang.Thread.run(libgcj.so.14)
2014-12-02 16:33:07.778 +0000 Exception:
Header Chunk. Image width:22 height:22 depth:8 color type:6 compression type:0 filter type:0 interlace:0
java.lang.NoSuchMethodError: method java.net.Socket.<init> with signature (Ljava.net.Proxy;)V was not found.
at com.elsitech.screenconnect.EndPointManager.run(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.runThread(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.access$000(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner$1.run(Unknown Source)
at java.lang.Thread.run(libgcj.so.14)
2014-12-02 16:35:52.746 +0000 Exception:
Header Chunk. Image width:22 height:22 depth:8 color type:6 compression type:0 filter type:0 interlace:0
java.lang.NoSuchMethodError: method java.net.Socket.<init> with signature (Ljava.net.Proxy;)V was not found.
at com.elsitech.screenconnect.EndPointManager.run(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.runThread(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner.access$000(Unknown Source)
at com.elsitech.screenconnect.ThreadRunner$1.run(Unknown Source)
at java.lang.Thread.run(libgcj.so.14)



i got java using the following command:

sudo apt-get install default-jre
Scott  
#4 Posted : Monday, December 8, 2014 7:10:04 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
Hmm, not too sure.

Would you mind contacting our team we would be happy to help (https://www.screenconnect.com/Support)?

I'd really like to take a direct look at the server, if possible.

Edited by moderator Wednesday, October 26, 2016 2:34:16 PM(UTC)  | Reason: Not specified

ScreenConnect Team
RichBrown  
#5 Posted : Thursday, July 23, 2015 5:29:08 PM(UTC)
RichBrown


Rank: Newbie

Joined: 7/23/2015(UTC)
Posts: 2
Netherlands
Location: Amsterdam

Originally Posted by: Scott Go to Quoted Post
Hmm, not too sure.

Would you mind contacting our team we would be happy to help (https://www.screenconnect.com/Support)?

I'd really like to take a direct look at the server, if possible.




Was there any resolution to this? I have the same issue.

Thanks

Edited by moderator Wednesday, October 26, 2016 2:34:34 PM(UTC)  | Reason: Not specified

Reid  
#6 Posted : Friday, July 24, 2015 11:14:42 AM(UTC)
Reid


Rank: Administration

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 4/22/2010(UTC)
Posts: 475
Location: NC

Was thanked: 17 time(s) in 15 post(s)
I cannot find a ticket that is related to this particular forum post, so I am unsure of what the resolution was here. If you would, contact our team we would be happy to help (https://www.screenconnect.com/Support) and they should be able to assist you with this. Please reference this forum post in the email.

Edited by moderator Wednesday, October 26, 2016 2:22:43 PM(UTC)  | Reason: Not specified

ScreenConnect Team
normva  
#7 Posted : Wednesday, August 5, 2015 9:44:56 PM(UTC)
normva


Rank: Member

Joined: 2/6/2014(UTC)
Posts: 13
United States
Location: virginia

Thanks: 2 times
I have this issue also. Would like to learn what the resolution is. Thanks, Norm
ldweldonwci  
#8 Posted : Friday, November 27, 2015 2:07:34 PM(UTC)
ldweldonwci


Rank: Newbie

Joined: 1/10/2015(UTC)
Posts: 5
United States
Location: Gouverneur NY

I had the issue, as well, and got the hint on resolution from Scott's #2 post about the log file and Phillip's response about java (apt-get install default-jre).

There were two log files; one apparently for IPV4 and the other (I suppose) IPV6. I first thought perhaps SC was using the IPV6 route and ignoring my IPV4 routes (DHCP). However, I checked java as above and it installed. Until that worked I was sure java was installed.

Now it installs and connects. Would it not be wise for the installer to check for java?

Best regards.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.