logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
michaeldale  
#1 Posted : Monday, October 20, 2014 10:06:27 PM(UTC)
michaeldale


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 11/10/2013(UTC)
Posts: 73
Australia

Thanks: 4 times
Was thanked: 4 time(s) in 4 post(s)
Hi All,

Recently enabled SSL on WebServerListenUri and this has caused Java to throw errors on connecting (only when using the Java client).

Wondering if anyone else has this issue:

com.sun.deploy.net.FailedDownloadException: Unable to load resource: (https://connect.dalegroup.net:443/Bin/Elsinore.ScreenConnect.Client.jar?version-id=4.4.7175.5302, 4.4.7175.5302)
at com.sun.deploy.net.DownloadEngine.actionDownload(Unknown Source)
at com.sun.deploy.net.DownloadEngine.downloadResource(Unknown Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.deploy.cache.ResourceProviderImpl.getResource(Unknown Source)
at com.sun.javaws.LaunchDownload$DownloadTask.call(Unknown Source)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

Looks like a Java bug but don't know how to fix that:
https://support.roambi.c...-alert-unrecognized-name
Cloud Helpdesk: http://bluetrait.com/

Scott  
#2 Posted : Friday, October 24, 2014 1:15:42 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
I'm not sure what's happening here, but I'm going to shoot you an email so we can take a closer look at your server.
ScreenConnect Team
Paul Moore  
#3 Posted : Friday, October 24, 2014 2:50:37 PM(UTC)
Paul Moore


Rank: Advanced Member

Medals: Level 3: Shirt off your back! Received 25 Thanks!

Joined: 9/16/2011(UTC)
Posts: 334

Thanks: 5 times
Was thanked: 70 time(s) in 44 post(s)
The TLS setup is a bit of a mess, which is likely causing Java to fail.

https://www.ssllabs.com/...?d=connect.dalegroup.net

You have proto intolerance, SSLv3 (disable this!), weak ciphers, no specified order, java 8b connectivity issues etc. I'd sort those first, as Java won't play ball if the endpoint isn't configured properly.
ScreenConnect Reporting - Collects live & historical information including session times.
http://goo.gl/nrF3e9
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.