logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
FCs  
#1 Posted : Wednesday, April 25, 2018 5:58:20 PM(UTC)
FCs


Rank: Member

Joined: 1/22/2014(UTC)
Posts: 16

I’m having some problems moving the login page from the default http://domain.com:8040 to https://subdomain.domain.com. Screenconnect is running on a Debian VPS with Plesk. First I created a subdomain in Plesk and tried to modify the key

<add key="WebServerListenUri" value="http://subdomain.domain.com:80/">

for some reason it’s not working, I lose the access on 8040 but can’t connect on 80. What am I doing wrong?
shawnkhall  
#2 Posted : Thursday, April 26, 2018 9:16:34 PM(UTC)
shawnkhall


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/6/2014(UTC)
Posts: 297
Man
United States

Thanks: 7 times
Was thanked: 25 time(s) in 22 post(s)
Most likely Plesk is already consuming port 80 for another service (httpd or IIS) and you'll either need to disable it through the IP feature in Plesk or use a different port.

Note that you can use WebServerAlternateListenUri, too. This might be a better solution for you while you're migrating between domains.

Also, check this out, it's MUCH easier to get it working as a subdirectory by piggybacking an existing site.

FCs  
#3 Posted : Friday, April 27, 2018 11:33:12 AM(UTC)
FCs


Rank: Member

Joined: 1/22/2014(UTC)
Posts: 16

Thanks for the response. I simply can’t get it work. On this server there are multiple websites running so I can’t disable apache.

Piggybacking gives me a simple not found on the directory set /in the kb there is a line that states that SSL piggybacking is only available for Windows servers/

Tried this methode: https://tylermade.net/20...ith-nginx-reverse-proxy/ no luck, I just see an empty site

I even tried to use iframe too but the browsers block it because of the mixed content.

Another problem is that screenconnect fails to restart about the the second time after a configuration mod. /Failed to start service: System.CannotUnloadAppDomainException: Appdomain is already being unloaded./

I spent many hours solving this simple problem I never thought it would be this difficult.
FCs  
#4 Posted : Friday, April 27, 2018 11:46:53 AM(UTC)
FCs


Rank: Member

Joined: 1/22/2014(UTC)
Posts: 16

right after I wrote the post above I could resolve the proxy pass problem, now it's working, thanks again

Edited by user Friday, April 27, 2018 12:25:16 PM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.