The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.



Go to last post Go to first unread
#1 Posted : Tuesday, December 19, 2017 8:47:36 PM(UTC)

Rank: Guest

Joined: 12/19/2017(UTC)
Posts: 1

I have a pretty vanilla installation of Debian Stretch (the latest build) with all of the latest apt-get update applied. I am trying to get ScreenConnect installed on this server as it would be far more stable than our previous Windows Server installation. I am approaching this as a brand new installation.

I followed the instructions on this KB article: https://docs.connectwise...trol_On-Premise_on_Linux

Used Option 1 to install ScreenConnect:
workingDirectory=~/scInstall; downloadUrl="https://www.screenconnect.com/Download?Action=DownloadLatest&Platform=Linux&PreRelease=false"; rm -rf $workingDirectory; mkdir $workingDirectory; (cd $workingDirectory; if which wget; then wget -O sc.tar.gz "$downloadUrl"; else curl -L "$downloadUrl" > sc.tar.gz; fi; tar xf sc.tar.gz; $(find . -name install.*);); rm -rf $workingDirectory;

Everything works great, the install finishes without error and I am prompted to browse to http://localhost:8040/Host. When I try to go there, no page is served. When I try from another machine by using I get the same result, "This site can’t be reached"

I checked the log at /var/log/screenconnect and I am getting this:

Unhandled Exception:
System.TypeInitializationException: An exception was thrown by the type initializer for libc ---> System.DllNotFoundException: /libx32/libdl.so.2
at (wrapper managed-to-native) ScreenConnect.MonoNative+libdlProxy:dlopenPlatformInvoke (void*,int)
at ScreenConnect.MonoNative+libdlProxy.dlopen (System.Void* , Int32 ) [0x00000] in <filename unknown>:0
at ScreenConnect.MonoToolkit+MonoDiskNativeLibrary.TryLoadNativeLibrary (System.String libraryPath) [0x00000] in <filename unknown>:0
at ScreenConnect.DiskNativeLibrary..ctor (System.String libraryPath) [0x00000] in <filename unknown>:0
at ScreenConnect.MonoToolkit+MonoDiskNativeLibrary..ctor (System.String libraryPath) [0x00000] in <filename unknown>:0
at ScreenConnect.MonoToolkit.LoadNativeLibraryFromDisk (System.String libraryPath) [0x00000] in <filename unknown>:0
at ScreenConnect.NativeLibrary.LoadLibrary (System.String libraryName, System.Type lookInAssemblyWithType) [0x00000] in <filename unknown>:0
at ScreenConnect.NativeLibrary.LoadLibrary (System.Type type, System.Type lookInAssemblyWithType) [0x00000] in <filename unknown>:0
at ScreenConnect.NativeLibrary.LoadProxy (System.Type type, System.Type lookInAssemblyWithType) [0x00000] in <filename unknown>:0
at ScreenConnect.NativeLibrary.LoadProxy[libc] (System.Type lookInAssemblyWithType) [0x00000] in <filename unknown>:0
at ScreenConnect.MonoNative+libc..cctor () [0x00000] in <filename unknown>:0
--- End of inner exception stack trace ---
at ScreenConnect.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0

Has anyone run into this? I've tried everything and I am all out of ideas. I checked /libx32 and libdl.so.2 is in fact present.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.