The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.



Go to last post Go to first unread
#1 Posted : Monday, November 6, 2017 9:44:59 PM(UTC)

Rank: Guest

Joined: 11/6/2017(UTC)
Posts: 1
United States
Location: Texas

Did a new install, so I ran the installation from LT (or 'Automate', but that's a longer word to type than 'LT'), and got the SC (or 'Connect', but again...longer word) server installed and running.

Now, we've upgraded a few times, and I think we even had to do a re-install at some point, so a lot of the LT agents are showing multiple SC versions. Tried running the script that pops up whenever you do the Install Wizard from Dashboard > Config > Integrations > ScreenConnect, but I don't think that really did much cleanup.

So, I created my own scripts - based on 'Application Name' that essentially just run
wmic product where name="ScreenConnect Client (xxxxxxxxxx)" call uninstall /nointeractive
, where the x's are 1 of the 8 alpha-numeric identifiers, and the scripts were just run on any device that had an application name on the software tab that matched. You get the idea.

After running the scripts, and then later running the Update Software command, then refreshing the System Cache - I've made remarkably little headway.

Meanwhile - ScreenConnect has been able to go out and install the new agents, apparently, but it's only at 50% since Friday. Attempts to install manually show as 'OK' in the Output on the 'Commands' tab, and I don't know what that means, since - clearly - it's not actually installing anything. And try as I might, I can't find any documentation on how to deploy to everything, or how the deployment works, or what to check if the slow-as-balls manual approach doesn't work, or anything.

I found a script here that will remove ALL instances of screenconnect - but, I can't even import it. LabTech goes through the motions, sure - but no search for the script after import turns anything up.

Now - if I manually hit each machine, and run that same exact command from above on it, works no problem. So maybe this is a LabTech issue. Or something. A good way to tell if it is, would be to know how exactly the SC plugin for LT works, in terms of deployment...because then I could see if it's getting gunked up in the SC side, or in the LT side.

Thanks for any help in advance.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.