logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
michaelb  
#1 Posted : Tuesday, August 28, 2018 4:43:49 PM(UTC)
michaelb


Rank: Guest

Joined: 8/28/2018(UTC)
Posts: 1

I recently tried setting up the headless ScreenConnect 6.7 client on a Raspberry Pi Zero W (ARMv6) running Raspbian Stretch Lite. The computer is actually just acting as a simple Nginx reverse proxy.

The script the support page provided for troubleshooting headless operation shows the framebuffer should be working, it was still not working on my device (blank black screen). I was able to get something working by updating the systemd script to turn off java's headless operation and use the X virtual framebuffer (xvfb) and xterm, but it really wasn't what I was looking for.

The true headless operation via the /dev/fb0 framebuffer would be much preferable. Long story short, I now know that ARM devices aren't supported, and the reason that it was failing was ScreenConnect's native library for the framebuffer operations was x86 and x64 only. This library is very tiny (6kb) and appears to have a handful of JNI calls that load the screen buffer into java.

I'd really love to get this working, so I was wondering if I would be able to get get an ARMv6 compiled version of the libscnative_x86.so, even if its not supported.

Otherwise, if ConnectWise is willing to release the C source code with the JNI calls for just this one 7kb library, I could make necessary modifications and recompile it myself for ARMv6.

I could decompile the existing x86 lib and try to mimic the JNI calls, but that is very error-prone and labor intensive. A detailed spec would be nice though if anyone has one.

Has anyone else tried this or been able to get headless client operation working on a Pi Zero?
SoCo_Systems  
#2 Posted : Wednesday, August 29, 2018 2:49:04 PM(UTC)
SoCo_Systems


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 1/29/2014(UTC)
Posts: 108
Man
United States
Location: Indianapolis, IN

Was thanked: 15 time(s) in 15 post(s)
I have absolutely no experience running it on a Rasberry Pi, but the blank black screen on a headless host is an issue I've run into on Windows PCs. The simple fix on those was to just plug in a cheap display emulator. You can get them on Amazon for under $10. One example: https://www.amazon.com/D...-1920x1080/dp/B079K3CQRT
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.