logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
itinfserv  
#1 Posted : Friday, March 24, 2017 12:29:58 PM(UTC)
itinfserv


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/11/2014(UTC)
Posts: 20

Was thanked: 1 time(s) in 1 post(s)
Has anyone got SC installed and able to manage Windows Server 2016 Core? Not sure if its possible at all, but thought I would ask
Scott  
#2 Posted : Friday, March 24, 2017 1:45:26 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,731
United States

Thanks: 3 times
Was thanked: 336 time(s) in 290 post(s)
Just to be clear, are you talking about installing the Access client or perhaps the server software?
ScreenConnect Team
itinfserv  
#3 Posted : Tuesday, March 28, 2017 2:13:58 PM(UTC)
itinfserv


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 2/11/2014(UTC)
Posts: 20

Was thanked: 1 time(s) in 1 post(s)
The Access client
Scott  
#4 Posted : Tuesday, April 11, 2017 1:43:47 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,731
United States

Thanks: 3 times
Was thanked: 336 time(s) in 290 post(s)
As far as I am aware it should be possible to install an Access client on Server 2016 Core, as long as the .NET requirements are met. I do not believe it requires the full Windows experience, however (File explorer, etc).

Have you tried to install a client and have it not work?
ScreenConnect Team
wil  
#5 Posted : Monday, March 12, 2018 8:52:47 AM(UTC)
wil


Rank: Member

Joined: 6/10/2015(UTC)
Posts: 26

Was thanked: 1 time(s) in 1 post(s)
Rather than open a new topic, I was wondering if there is any more feedback here?

I can install the client, I can do most things - draw, run toolbox items, run commands and more...

...However, I can only see a black screen. I can type fine but I can't move the mouse or see what is happening.

To be honest, the main reason I wanted this was for the commands tab so I can run a few things quick, but, not sure if this is a bug relating to core or by design.

I just find it weird that drawing works and yet I can't see the screen!
Scott  
#6 Posted : Monday, March 12, 2018 11:15:16 AM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,731
United States

Thanks: 3 times
Was thanked: 336 time(s) in 290 post(s)
@wil just to be safe, what version of ConnectWise Control are you running?

Is the client completely up to date with the server?
ScreenConnect Team
wil  
#7 Posted : Monday, March 12, 2018 12:46:32 PM(UTC)
wil


Rank: Member

Joined: 6/10/2015(UTC)
Posts: 26

Was thanked: 1 time(s) in 1 post(s)
@Scott

From version check:

Your Version:6.2.12963.6312
Latest Version:6.5.16479.6613
Latest Eligible Version:6.3.13446.6374

I haven't updated for a while (CWA install pending) but I think my version is well after 2016 core release.

And the 2016 box is running the latest version available.

To be honest again, I can do what I want (being able to run commands quick), but, would be great to understand why this isn't working.
Scott  
#8 Posted : Monday, March 12, 2018 1:40:20 PM(UTC)
Scott


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,731
United States

Thanks: 3 times
Was thanked: 336 time(s) in 290 post(s)
We added handling to an AccessViolationException bug that originates within the Windows desktop duplication API in version 6.4 of ConnectWise Control.

Now, I can't say exactly when we added it (likely before the 6.3 stable release), but we also included a way to force the screen capturer to fallback to the more reliable (but less efficient) BitBlt method via an environmental variable. You can create a variable called 'ScreenConnectDisableDesktopDuplication' on the Server 2016 Core machine and set it to true to prevent it from attempting to hook into the other API.

I'm pretty sure this wasn't added in 6.2, but since your license is eligible for some releases of 6.3 it might be worth trying out.
ScreenConnect Team
Michael L  
#9 Posted : Monday, March 12, 2018 5:59:48 PM(UTC)
Michael L


Rank: Administration

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/18/2015(UTC)
Posts: 88
Man
United States

Thanks: 9 times
Was thanked: 13 time(s) in 11 post(s)
Server 2016 core doesn't have a desktop GUI installed. You can still install the client and connect in, but you'll get a black screen because there's nothing displayed in the Console of the OS, and no background image. Are you able to use Send Ctrl+alt+del in a session to open up task manager? From the menu on there, you should still be able to run commands to open up programs, but without the full desktop experience you'd get with full 2016, it's going to be a bit of a pain to use.

This is by design though since it's a Core OS.

Side note, the desktop duplication item wasn't built in until 6.3, so you'd need to add the environmental variable that Scott mentioned. But I don't think that's going to help in this case :)
ConnectWise Control (ScreenConnect) Support Team
wil  
#10 Posted : Tuesday, March 13, 2018 12:33:47 AM(UTC)
wil


Rank: Member

Joined: 6/10/2015(UTC)
Posts: 26

Was thanked: 1 time(s) in 1 post(s)
Thanks both Scott and Michael,

@Scott - I've bought CWA and am onboarding now... I just wasn't sure if I was going to keep Control separate... If they didn't, I was going to use that as the main one and keep mine just for meetings/support... but if I can carry on with one server, I'll probably renew the license.... so, I'll give it a few days and then I'll upgrade to hopefully the latest.

@Michael L, Not sure if I explained correctly - this is Server Core, not server Nano... It has a console session (AFAIK, but, I am new to it) and winforms (even some .net) apps (Like task manager as you said)... I'm using Server Manager remotely to administer it, but, there are rare times when I just want to do something quick locally, or diagnose etc. Are you saying that even if I follow Scott's advice above, I still won't be able to see the console session remotely?
Michael L  
#11 Posted : Tuesday, March 13, 2018 1:36:46 AM(UTC)
Michael L


Rank: Administration

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/18/2015(UTC)
Posts: 88
Man
United States

Thanks: 9 times
Was thanked: 13 time(s) in 11 post(s)
With Core, you can still log in and run stuff from the task manager, but Windows Explorer isn't available to the console session - you can only use it within a terminal session (like rdp), so running diagnostics could get to be a little tricky.

The difference between Core and Nano is even less functionality for the interface makes it into Nano, with no local logon available at all.

https://msdn.microsoft.com/en-us/library/mt588479(v=vs.85).aspx

https://docs.microsoft.c...started-with-nano-server

Ultimately, Control/SC hooks into the desktop GUI on the local Console session for you to be able to connect in. Without that, you'll still be able to run the client, send commands, use the toolbox, etc., but you don't get the same kind of experience as you'd have with the full desktop.

Edited by user Tuesday, March 13, 2018 1:37:20 AM(UTC)  | Reason: Not specified

ConnectWise Control (ScreenConnect) Support Team
wil  
#12 Posted : Tuesday, March 13, 2018 3:55:22 AM(UTC)
wil


Rank: Member

Joined: 6/10/2015(UTC)
Posts: 26

Was thanked: 1 time(s) in 1 post(s)
@Michael - Sorry if I wasn't clear - I understand that Windows Explorer isn't available... When I said about just seeing black, I mean a complete black box, not a command prompt window or similar.

The reason I thought this was a bug rather than anything else is that there is a regular console/session 0 AFAIK (and sorry if I am wrong), just defaults the shell from explorer to cmd and removes all other overhead... I tested it with VNC and teamviewer and it works fine... ScreenConnect however doesn't render (but shows the correct screenshot in preview and allows keyboard input).

The issue is, I can run simple commands from within Screenconnect, but, I want to run sconfig.cmd which is interactive.

See this screenshot, you can see teamviewer works fine:

https://imgur.com/a/6F5Ex
Michael L  
#13 Posted : Tuesday, March 13, 2018 12:04:56 PM(UTC)
Michael L


Rank: Administration

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 8/18/2015(UTC)
Posts: 88
Man
United States

Thanks: 9 times
Was thanked: 13 time(s) in 11 post(s)
Thanks for the screenshot! The Control/SC client should work the same way as you see in TV and VNC (that's what I was describing earlier). In that case, the blank screen could be a few things, so that environmental variable Scott mentioned would be something to test, or just upgrading the server and client to 6.3 so you don't need to add the variable.
ConnectWise Control (ScreenConnect) Support Team
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.