The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.



Go to last post Go to first unread
#1 Posted : Monday, March 18, 2013 2:11:57 AM(UTC)

Rank: Member

Joined: 3/18/2013(UTC)
Posts: 23
Location: Si

Thanks: 1 times
Please advise how to change the Date and Time format in the application (eg. in Audit) to dd/MM/yyyy and HH:MM)

#2 Posted : Thursday, March 28, 2013 4:31:59 PM(UTC)

Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/9/2010(UTC)
Posts: 2,061

Thanks: 1 times
Was thanked: 393 time(s) in 188 post(s)
It should localize to your culture format. But we should also let you specify a date format string in web resources... I'll put in an enhancement request for it and try to remember to do it next time we're doing something that requires changing the web resources.

You can modify this line in Audit.ascx if you're really in a hurry:

						<%# ((SessionAuditEntry)Container.DataItem).Time.ToLocalTime() %>
ScreenConnect Team
#3 Posted : Tuesday, July 30, 2013 7:29:52 PM(UTC)

Rank: Newbie

Joined: 7/30/2013(UTC)
Posts: 8
Location: Australia

Thanks: 1 times
Hi Jake, I tried your suggestion re changing the line in Audit.ascx but had a little trouble.

My line in audit.ascx looks like this:

<%# this.GetAuditEntryDetailHtml((SessionAuditEntry)Container.DataItem) %>

(it is the only line of the 2 that even resembles the line in your post)

I made the change to look like this:

<%# this.GetAuditEntryDetailHtml(((SessionAuditEntry)Container.DataItem).Time.ToLocalTime()) %>

but it generated an error. I tried with and without the surrounding parenthesis.

Any ideas?
#4 Posted : Wednesday, February 8, 2017 12:18:53 AM(UTC)

Rank: Newbie

Joined: 7/30/2013(UTC)
Posts: 8
Location: Australia

Thanks: 1 times
Bumping this topic.

My previous issue was my own dyslexia I think, on review it was showing dates in the correct format to my locale, D/M/YYYY. That was in V3

I recently upgraded to V6.0.11622.6115 and the date format is M/D/YYYY. I checked it several times to make sure.

I also checked the Regional Settings on the server on which it is installed, I checked the Regional Settings on my local PC and they all show it as English (Australia) with the short date format D/M/YYYY

I even tried the advice from previous replies. No joy.

I have searched for date format etc but no joy there either - am I the only one with this issue?

Thanks for any help.
#5 Posted : Thursday, August 10, 2017 8:22:27 AM(UTC)

Rank: Member

Joined: 2/10/2011(UTC)
Posts: 24
Location: Eukey OZ

Thanks: 4 times
I too have this problem
server 2012R2 is set as follows
Display Language English UK
Input language English Australia
Format English Australia
Location Australia

SC admin panel under appearance shows for both Web and Client resources a key of English (United States)

Our issue is with dates in messages
Hopefully someone at CW will look at this
Appreciate any assistance with this

Edited by user Thursday, August 10, 2017 8:23:19 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.