The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.



Go to last post Go to first unread
#1 Posted : Thursday, March 23, 2017 5:46:26 PM(UTC)

Rank: Guest

Joined: 3/22/2017(UTC)
Posts: 2
United States

I'm hoping someone can give me a hand with some issues I'm having with unattended access into several Fedora 25 / Gnome3 machines. I've searched the forums and have found other posts describing similar issues that weren't on-point, so I've started a new thread.

In looking through the similar issues, they all reference an issue with Java having screen drawing issues in Unity/metacity. The release notes for the latest version claim this is fixed (I don't work with Ubuntu/Canonical, so I have no way to know).

The remote installations are not headless, and they are all running GDM/Gnome3 GUI running with a user other than root. I've tried Wayland, X, and "Gnome Classic" from GDM, all with the same result. I'm unable to access these Gnome3 remote clients from a Fedora 25 / Gnome3, a MacOS 10.12.3, or a Windows 10 host.

It's not just a matter of seeing the remote GUI either: a mouse pointer appears on the host-side window (where the remote desktop would be expected), but interaction on the host side produces no effect on the guest/remote side (moving the mouse around in the host does absolutely nothing on the guest, etc.).

I checked the logs and I'm seeing this Java exception:

2017-03-23 10:38:10.206 -0700 Exception:
	at java.io.DataInputStream.readByte(DataInputStream.java:267)
	at com.screenconnect.MessageSerializer.deserialize(MessageSerializer.java:97)
	at com.screenconnect.EndPointManager.receiveMessage(EndPointManager.java:121)
	at com.screenconnect.EndPointManager$SocketEndPointManager.runIncomingThread(EndPointManager.java:319)
	at com.screenconnect.EndPointManager$SocketEndPointManager.access$100(EndPointManager.java:133)
	at com.screenconnect.EndPointManager$SocketEndPointManager$1.run(EndPointManager.java:197)
	at java.lang.Thread.run(Thread.java:745)

All machines (guest and host) should all be running this Java:

tfry  ~  java -version
openjdk version "1.8.0_121"
OpenJDK Runtime Environment (build 1.8.0_121-b14)
OpenJDK 64-Bit Server VM (build 25.121-b14, mixed mode)

Running proprietary Java is out of the question.

Thanks in advance. :-)

Edited by user Thursday, March 23, 2017 5:50:41 PM(UTC)  | Reason: Typo in description

#2 Posted : Friday, March 24, 2017 11:57:31 AM(UTC)

Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 3/28/2014(UTC)
Posts: 2,862
United States

Thanks: 3 times
Was thanked: 351 time(s) in 303 post(s)
Just so I get a clearer picture, can you post a screenshot of exactly what you're seeing?
ScreenConnect Team
#3 Posted : Sunday, April 2, 2017 2:09:47 AM(UTC)

Rank: Guest

Joined: 3/22/2017(UTC)
Posts: 2
United States

Scott, thank you for responding so quickly and I apologize for my slow response. I had a configuration error in X ... imagine that: once I finished actually troubleshooting the problem I found a solution!

Sorry for wasting your time. :-)

I guess this thread closed (or should be deleted), lol.

Edited by user Sunday, April 2, 2017 2:13:59 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.