logo

The ConnectWise Control forum has moved to ConnectWise University! This forum has been locked and is in read-only mode. Click here for instructions on how to access the new forum.

Welcome Guest! You can not login or register.

Notification

Icon
Error

Options
Go to last post Go to first unread
John  
#1 Posted : Thursday, May 1, 2014 2:03:02 PM(UTC)
John


Rank: Guest

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 3/25/2014(UTC)
Posts: 226

Thanks: 5 times
Was thanked: 12 time(s) in 11 post(s)
Many of you use the ClickOnce browser plugin for Chrome to help speed up the join process, particularly for techs who are entering and exiting sessions regularly. We have previously recommended a plugin to use, but we've recently switched our recommendation to a different one due to the old plugin showing ads. We suggest uninstalling the old one and installing this one:

https://chrome.google.co...bmjaobhdondofgdmnbidlgfh

We're not enthusiastic about relying on a 3rd party app, and we'd go ahead and create one ourselves, but the ability for anyone (per Google) to do this kind of plugin is going away soon, so it'd be a moot point shortly anyway.

Let us know if you have any questions.

nathand  
#2 Posted : Wednesday, May 7, 2014 8:51:37 PM(UTC)
nathand


Rank: Member

Joined: 4/16/2014(UTC)
Posts: 10
United States
Location: Washington

Could you please elaborate on "ut the ability for anyone (per Google) to do this kind of plugin is going away soon"?

And what will you do in regard to this when Google finally prevents this. How will the seamless join (and speed up) process be maintained in these browsers?

Paul Moore  
#3 Posted : Wednesday, May 7, 2014 9:31:18 PM(UTC)
Paul Moore


Rank: Advanced Member

Medals: Level 3: Shirt off your back! Received 25 Thanks!

Joined: 9/16/2011(UTC)
Posts: 334

Thanks: 5 times
Was thanked: 70 time(s) in 44 post(s)
Google are dropping support for the ClickOnce.

So far as "what happens next", no idea :)
ScreenConnect Reporting - Collects live & historical information including session times.
http://goo.gl/nrF3e9
thanks 1 user thanked Paul Moore for this useful post.
John on 5/8/2014(UTC)
clickright  
#4 Posted : Saturday, May 31, 2014 4:53:39 AM(UTC)
clickright


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 5/15/2014(UTC)
Posts: 68
Canada

Thanks: 8 times
Was thanked: 2 time(s) in 2 post(s)
Originally Posted by: Cresona Go to Quoted Post
Google are dropping support for the ClickOnce.

So far as "what happens next", no idea :)


Oh my! Has this already happened in 35.0.1916.114 m? Suddenly I can no longer run ClickOnce sessions, even with ClickOnce Helper 1.1.0.
rmmccann  
#5 Posted : Tuesday, June 3, 2014 4:43:27 PM(UTC)
rmmccann


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 12/16/2012(UTC)
Posts: 184
Location: MN, USA

Thanks: 17 times
Was thanked: 21 time(s) in 18 post(s)
Originally Posted by: clickright Go to Quoted Post
Originally Posted by: Cresona Go to Quoted Post
Google are dropping support for the ClickOnce.

So far as "what happens next", no idea :)


Oh my! Has this already happened in 35.0.1916.114 m? Suddenly I can no longer run ClickOnce sessions, even with ClickOnce Helper 1.1.0.


This *was* working for me on that version with the ClickOnce Helper extension. I just upgraded to the new 64bit dev build of chrome and found that it no longer works.

This really is disappointing.
Jake  
#6 Posted : Tuesday, June 3, 2014 5:07:51 PM(UTC)
Jake


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/9/2010(UTC)
Posts: 2,061

Thanks: 1 times
Was thanked: 393 time(s) in 188 post(s)
The plugin contains an NPAPI dll, which is 32-bit.

Google is trying to deprecate NPAPI, which is why we said above that the whole thing may be going away.

I don't know what the author will do about 64-bit.

I'm not sure they even have a path for Chrome extensions to include 64-bit NPAPI dlls.
ScreenConnect Team
rmmccann  
#7 Posted : Tuesday, June 3, 2014 6:05:08 PM(UTC)
rmmccann


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 12/16/2012(UTC)
Posts: 184
Location: MN, USA

Thanks: 17 times
Was thanked: 21 time(s) in 18 post(s)
Originally Posted by: Jake Go to Quoted Post
The plugin contains an NPAPI dll, which is 32-bit.

Google is trying to deprecate NPAPI, which is why we said above that the whole thing may be going away.

I don't know what the author will do about 64-bit.

I'm not sure they even have a path for Chrome extensions to include 64-bit NPAPI dlls.


I guess I'm less interested in what the plugin author will do and more interested in what YOUR team will do, since you are the ones I am paying. I can workaround the problem by using IETab on my Windows systems, but I don't consider another browser to be a long term solution.

I should add that I'm not trying to be overly critical. Just saying that an alternative solution for Google Chrome would be a good thing.

Edited by user Tuesday, June 3, 2014 6:12:14 PM(UTC)  | Reason: Not specified

Jeff  
#8 Posted : Thursday, June 5, 2014 2:14:35 AM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
We are looking at several options for how to best handle this. A few options available to us its about deciding what avenue will be the best for customers short and long term. We will keep the community updated as we make decisions.
ScreenConnect Team
thanks 1 user thanked Jeff for this useful post.
Mitsol on 6/6/2014(UTC)
Amgeek  
#9 Posted : Tuesday, June 10, 2014 11:15:03 PM(UTC)
Amgeek


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 3/25/2013(UTC)
Posts: 30
Location: Upstate NY

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
Any news?
Jeff  
#10 Posted : Wednesday, June 11, 2014 3:29:19 PM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
Not at this point but it will probably still be a while before Chrome completely kills the existing functionality. We are not really waiting until that happens but we do have some breathing room as we look at options. Focus right now is getting 4.4 out and 5.0 to pre-release. After that we will look at this more closely.
ScreenConnect Team
rmmccann  
#11 Posted : Wednesday, June 11, 2014 3:39:17 PM(UTC)
rmmccann


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 12/16/2012(UTC)
Posts: 184
Location: MN, USA

Thanks: 17 times
Was thanked: 21 time(s) in 18 post(s)
Originally Posted by: Amgeek Go to Quoted Post
Any news?


If you are accessing your sessions from a Windows host, you can use the following workaround with Chrome:

Install IETab and set your ScreenConnect sites as AutoURLs. Also set compatibility mode to IE9 Forced Standards.

Open IE. Add your ScreenConnect sites to the Trusted or Intranet Zones.

From there, when you access your site in Chrome, it should automatically open it in an IETab. The only issue I've found is that switching between Session groups/Meetings/etc you sometimes have to hit "refresh" as the autorefresh code does not seem to work well in IE. I found that IE9 Forced Standards mode and adding my site to Trusted also allowed me to ClickOnce properly instead of asking to download the EXE and run it or giving me some kind of security prompt.
dittobox  
#12 Posted : Friday, June 13, 2014 5:05:12 PM(UTC)
dittobox


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/30/2013(UTC)
Posts: 35
Man
Location: Vancouver, WA

Thanks: 12 times
Was thanked: 1 time(s) in 1 post(s)
I am on 37.0.2041.4 dev-m of Chrome and ClickOnce isn't working, I'm required to download the Stub EXE. I don't know when 37 comes out in the beta or release channels but it's definitely removing support for it.
dittobox  
#13 Posted : Wednesday, August 6, 2014 7:39:37 PM(UTC)
dittobox


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/30/2013(UTC)
Posts: 35
Man
Location: Vancouver, WA

Thanks: 12 times
Was thanked: 1 time(s) in 1 post(s)
I'm on Chrome 38.0.2101.0 beta-m (64-bit) now. Still no dice. Is there any progress on a fix for this?
Jeff  
#14 Posted : Thursday, August 7, 2014 2:46:38 PM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
Work is being done, not sure which option they are going to go with. We will certainly add info as we know more.
ScreenConnect Team
Jeffrey  
#15 Posted : Wednesday, August 27, 2014 3:34:41 AM(UTC)
Jeffrey


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 6/2/2014(UTC)
Posts: 42
Canada

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
Was excited to try chrome 64bit stable today but had to revert when I discovered SC/clickonce no longer worked. For now I will live with 32bit, but I just want to add my name to the list of people hoping for a solution to this.
ivanskie  
#16 Posted : Tuesday, September 2, 2014 10:16:29 PM(UTC)
ivanskie


Rank: Advanced Member

Joined: 12/3/2013(UTC)
Posts: 56
Location: Canada

Thanks: 5 times
+1
AustinKnight  
#17 Posted : Wednesday, September 3, 2014 2:45:51 PM(UTC)
AustinKnight


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/16/2012(UTC)
Posts: 307
Location: Oregon

Thanks: 62 times
Was thanked: 10 time(s) in 10 post(s)
+1
JASON T. AUSTIN
Lead Network Engineer
Falcon Development, Inc.
www.falcondevelopment.com

DanCocke  
#18 Posted : Wednesday, September 3, 2014 5:34:55 PM(UTC)
DanCocke


Rank: Newbie

Joined: 9/3/2014(UTC)
Posts: 1
United States
Location: Knoxville TN

+1
Dan Cocke
Symetrix Network & Computer Services
Knoxville, Tennessee
www.symetrixnet.com
dittobox  
#19 Posted : Thursday, September 4, 2014 4:02:51 AM(UTC)
dittobox


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/30/2013(UTC)
Posts: 35
Man
Location: Vancouver, WA

Thanks: 12 times
Was thanked: 1 time(s) in 1 post(s)
Would a permanently installed, host-side application with a url-handler (a la Mac OS X) be a way around this?
Jake  
#20 Posted : Thursday, September 4, 2014 7:41:57 PM(UTC)
Jake


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/9/2010(UTC)
Posts: 2,061

Thanks: 1 times
Was thanked: 393 time(s) in 188 post(s)
Originally Posted by: dittobox Go to Quoted Post
Would a permanently installed, host-side application with a url-handler (a la Mac OS X) be a way around this?


This is already in 5.0, but as one of the secondary options. We'll leave it as a secondary option until we need to bump it up.
ScreenConnect Team
rmmccann  
#21 Posted : Tuesday, September 9, 2014 7:01:35 PM(UTC)
rmmccann


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 12/16/2012(UTC)
Posts: 184
Location: MN, USA

Thanks: 17 times
Was thanked: 21 time(s) in 18 post(s)
Originally Posted by: Jake Go to Quoted Post
Originally Posted by: dittobox Go to Quoted Post
Would a permanently installed, host-side application with a url-handler (a la Mac OS X) be a way around this?


This is already in 5.0, but as one of the secondary options. We'll leave it as a secondary option until we need to bump it up.


I would consider bumping it up already. You can no longer directly search for and find any ClickOnce plugins for Chrome in the Store. I had to google to find another link to download the plugin on a fresh install. It would seem within the next few months, it likely will be unavailable except via third party, and only until 64bit is forced upon us.
Konceptech.net  
#22 Posted : Thursday, September 11, 2014 2:56:14 PM(UTC)
Konceptech.net


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 7/26/2013(UTC)
Posts: 69
Canada
Location: Quebec

Thanks: 10 times
Was thanked: 3 time(s) in 2 post(s)
+1
Konceptech.net  
#23 Posted : Thursday, September 11, 2014 3:04:53 PM(UTC)
Konceptech.net


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 7/26/2013(UTC)
Posts: 69
Canada
Location: Quebec

Thanks: 10 times
Was thanked: 3 time(s) in 2 post(s)
Jeff  
#24 Posted : Thursday, September 11, 2014 10:32:10 PM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
Thanks for the feedback, we will certainly take into consideration. Looking around to see if there are any gotchas that we may have missed or not thought of before making it the primary. But I'm sure it will not be too long before we make that change.
ScreenConnect Team
DanielUK  
#25 Posted : Tuesday, September 16, 2014 7:30:54 AM(UTC)
DanielUK


Rank: Advanced Member

Medals: ScreenConnect Advisor: Focus Group MemberLevel 1: Random Act of Kindness! Received One Thanks!

Joined: 10/14/2013(UTC)
Posts: 89
United Kingdom

Thanks: 19 times
Was thanked: 9 time(s) in 7 post(s)
I don't really understand what is changing and who's fault things are, but I use Chrome on a PC and have only ever installed the public release version which keeps itself up to date.

This morning when trying to connect to a client, double clicking their entry in the Screenconnect session list didn't connect me, but downloaded a file instead. I noticed a banner along the top of the Screenconnect window suggesting I install "ClickOnce Helper", which I did and I was able to connect again. It installed v1.10.

Looking at the list of extensions, I also have installed - but disabled and greyed out - "ClickOnce for Google Chrome" which has a note beside it saying "This extension violates the Chrome Web Store policy".

Has someone fixed what this thread is saying will break, or is what will break still going to break?
dittobox  
#26 Posted : Tuesday, September 16, 2014 10:23:33 PM(UTC)
dittobox


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/30/2013(UTC)
Posts: 35
Man
Location: Vancouver, WA

Thanks: 12 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: DanielUK Go to Quoted Post
I don't really understand what is changing and who's fault things are, but I use Chrome on a PC and have only ever installed the public release version which keeps itself up to date.

This morning when trying to connect to a client, double clicking their entry in the Screenconnect session list didn't connect me, but downloaded a file instead. I noticed a banner along the top of the Screenconnect window suggesting I install "ClickOnce Helper", which I did and I was able to connect again. It installed v1.10.

Looking at the list of extensions, I also have installed - but disabled and greyed out - "ClickOnce for Google Chrome" which has a note beside it saying "This extension violates the Chrome Web Store policy".

Has someone fixed what this thread is saying will break, or is what will break still going to break?


ScreenConnect uses a functionality of .NET and Windows called ClickOnce to make downloading and installing the ScreenConnect client/host software very easy. For Chrome users in the past we've had to either manually start these ClickOnce profiles with a small EXE or let the browser handle it through an extension/plugin.

Our problem now is that Google and the Chromium project have removed NPAPI (Netscape Plugin Application Programming Interface) plugin support within 64-bit (and soon to be 32-bit) Chrome, due to security issues with NPAPI. All plugins that use this Netscape API are no longer allowed in the Chrome webstore, and will not install on the latest (from 37 onward) version of Chrome. As far as anyone can tell, the only way to allow the use of ClickOnce within Chrome is to use NPAPI to develop a plugin. Now that it's gone, Chrome users cannot start or connect to sessions using ClickOnce unless they manually download the stub EXE.
Jeff  
#27 Posted : Friday, September 19, 2014 3:34:20 PM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
Users in 5.0 and forward will start to see new client options that should help with these changes in Chrome. They will not be the default in 5.0 (most likely) as we collect feedback but they will be present. As we complete more testing here we will certainly update this post and the community via different mediums. The blog and soical media (twitter/facebook) are good ways to learn about these updates.
ScreenConnect Team
thanks 1 user thanked Jeff for this useful post.
clarkfellows on 9/19/2014(UTC)
rmmccann  
#28 Posted : Thursday, September 25, 2014 12:51:59 PM(UTC)
rmmccann


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 12/16/2012(UTC)
Posts: 184
Location: MN, USA

Thanks: 17 times
Was thanked: 21 time(s) in 18 post(s)
I just received a new Tab alert from my ClickOnce plugin ("ClickOnce for Google Chrome") that indicated they made an update and required a helper program in order to launch ClickOnce apps. I downloaded and installed the ZIP file. Seems the extension developer has a fix for this problem.

If I get a chance, I'll install the 64bit version of Chrome and see if it works as expected.
AustinKnight  
#29 Posted : Thursday, September 25, 2014 1:12:06 PM(UTC)
AustinKnight


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 5/16/2012(UTC)
Posts: 307
Location: Oregon

Thanks: 62 times
Was thanked: 10 time(s) in 10 post(s)
Does not work on the x64 system of chrome.
JASON T. AUSTIN
Lead Network Engineer
Falcon Development, Inc.
www.falcondevelopment.com

mylove4life  
#30 Posted : Thursday, September 25, 2014 8:12:22 PM(UTC)
mylove4life


Rank: Advanced Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 7/5/2010(UTC)
Posts: 112

Was thanked: 2 time(s) in 2 post(s)
I find it just as easy to use IE.
Jeff  
#31 Posted : Tuesday, September 30, 2014 9:21:11 PM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
There is a new join method that has been put into 5.0, here is forum post on that: http://forum.screenconne...e-support.aspx#post17703
ScreenConnect Team
rmmccann  
#32 Posted : Wednesday, October 1, 2014 7:45:54 PM(UTC)
rmmccann


Rank: Advanced Member

Medals: Level 2: Lent a Helping Hand! 10 Thanks!

Joined: 12/16/2012(UTC)
Posts: 184
Location: MN, USA

Thanks: 17 times
Was thanked: 21 time(s) in 18 post(s)
Originally Posted by: Jeff Go to Quoted Post
There is a new join method that has been put into 5.0, here is forum post on that: http://forum.screenconne...e-support.aspx#post17703


I'm glad to see progress, however I'm not going to deploy pre-release into production. I'm still running on 4.1.

samc  
#33 Posted : Monday, October 6, 2014 1:48:51 PM(UTC)
samc


Rank: Newbie

Joined: 10/6/2014(UTC)
Posts: 1

Just found this topic. The ClickOnce for Google Chrome extension seems to be working for me as of now (v2.0.7)

Edited by user Monday, October 6, 2014 1:49:24 PM(UTC)  | Reason: Not specified

vnny  
#34 Posted : Thursday, October 9, 2014 5:31:51 PM(UTC)
vnny


Rank: Member

Medals: Level 1: Random Act of Kindness! Received One Thanks!

Joined: 4/3/2013(UTC)
Posts: 22

Was thanked: 3 time(s) in 1 post(s)
Originally Posted by: samc Go to Quoted Post
Just found this topic. The ClickOnce for Google Chrome extension seems to be working for me as of now (v2.0.7)



for me this version is still not working. it just hangs there trying to join the session.
Jeff  
#35 Posted : Friday, October 10, 2014 3:42:08 PM(UTC)
Jeff


Rank: Administration

Medals: Level 4: Wise Old Owl! Received 100 Thanks!

Joined: 4/14/2010(UTC)
Posts: 1,785
Man
Location: Raleigh, NC

Thanks: 8 times
Was thanked: 156 time(s) in 122 post(s)
The ClickOnce for chrome option will need helper file downloaded on your machine. I am not sure what all options developer is implementing to alert users but I think something. Next time I get this I will post link.

But our new option in 5.0 is similar in that once you put client on your machine as a technician it facilitates the connections like you would see with this extension. If you are trying this and having problems please let us know we are happy to assist.

Edited by user Wednesday, October 26, 2016 2:38:01 PM(UTC)  | Reason: Not specified

ScreenConnect Team
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.